Bug report #10715

Error in MetaSearch browsing search results

Added by Paolo Cavallini about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:Tom Kralidis
Category:MetaSearch Catalogue Client
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:19105

Description

Adding the Italian CSW (http://www.rndt.gov.it/RNDT/CSW) to MetaSearch, and searching
for a common keyword ('province'), I get > 10 records. Only 5 are displayed, even if the dialog
reports "1-10 of 21 shown". If I click on the Next arrow, I get an error:

Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/MetaSearch/dialogs/maindialog.py", line 644,
in navigate
startposition=self.startfrom, esn='full')
File "/usr/share/qgis/python/owslib/csw.py", line 348, in getrecords2
self.results['matches'] = int(util.testXMLValue(val, True))
TypeError: int() argument must be a string or a number, not 'NoneType'

In the Log Console (tab 'Python warning') I had a warning:

... csw.py:356:UserWarning: CSW Server did not supply a nextRecord value
(it is optional), so the client should page througt the results in
another way.""

History

#1 Updated by Paolo Cavallini about 5 years ago

  • Assignee set to Tom Kralidis

#2 Updated by Paolo Cavallini about 5 years ago

  • Category changed from Python plugins to MetaSearch Catalogue Client

#3 Updated by Tom Kralidis about 5 years ago

  • Resolution set to up/downstream

FYI the CSW server / metadata provider is returning results sets with duplicate identifiers. Since the underlying CSW client in MetaSearch (OWSLib) is storing these as a dictionary, the duplicates are causing overwriting of records (hence 10 records become 5). Trace based on searching for 'province':

{'matches': 21, 'nextrecord': 11, 'returned': 10}

r_campan:16050011:20090527:104104
r_campan:16050011:20090527:104104
r_molise:{4E01E5F5-AA5E-4EA0-BEB6-D8CC49EEB129}
r_molise:{4E01E5F5-AA5E-4EA0-BEB6-D8CC49EEB129}
r_molise:{1743F3AC-265B-4BC3-BB76-A49C7B1857B3}
r_molise:{1743F3AC-265B-4BC3-BB76-A49C7B1857B3}
r_molise:{AB9E3733-C34E-40E8-ACB8-89DD2424BA2A}
r_molise:{AB9E3733-C34E-40E8-ACB8-89DD2424BA2A}
r_molise:{A22E2507-ECB0-4B0D-8D09-91237B2B0EFB}
r_molise:{A22E2507-ECB0-4B0D-8D09-91237B2B0EFB}

The CSW provider needs to update their records.

#4 Updated by Paolo Cavallini about 5 years ago

Thanks for the analysis. I'm forwarding it to RNDT peolpe.
Should we close this now?

#5 Updated by Tom Kralidis about 5 years ago

  • Status changed from Open to Closed

#6 Updated by Paolo Cavallini about 5 years ago

They are now aware of the problem, going to fix it.
Thanks.

Also available in: Atom PDF