Feature request #10629

Display data-defined symbology in legend

Added by Paolo Cavallini over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:19032

Description

It is possible to assign colours to vector items taking the value (as hex, html colours) from a filed of the associate table. However, this assignment will not appear on the legend, which is a major drawback.
More generally, displaying also data-defined symbology would be a major improvement.


Related issues

Related to QGIS Application - Bug report #8118: No usable legend when data defined symbology is used Closed 2013-06-19
Related to QGIS Application - Feature request #11491: When using data defined colors the map legend shows alwa... Open 2014-10-24

History

#1 Updated by Paolo Cavallini over 5 years ago

Duplicate of #8118

#2 Updated by Anita Graser about 5 years ago

Would you mind to close this one since discussions are now going on at #11491?

#3 Updated by Paolo Cavallini about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF