Bug report #10617

Wrong handling no data value -1e+32

Added by Miroslav Umlauf almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19021

Description

Wrong handling no data value whenever I open ers files or converted to tif, which have set NULL (no data value) to -1e+32. By default QGIS 2.2 (and dev master 2.3).

Info tool and plugin value tool takes this value properly as "no data". But in properties it is handled as standard value which causes style to be adjusted to -1e+32 to -1e+29 making it blank. Also histogram is affected. Adding additional no data value -1e+32 in "Transparency" tab fix all as it should be. The problem seems to be the no data value is by default calculated by some simplified manner causing to change value -1e+32 to some close, but different (see attached image).

qgis_no_data_value.png - Wrong handling no data value (15.4 KB) Miroslav Umlauf, 2014-06-18 12:36 AM


Related issues

Related to QGIS Application - Bug report #11049: Wrong properties statistics and style minimum and maximum... Closed 2014-08-13

History

#1 Updated by Miroslav Umlauf almost 6 years ago

  • Status changed from Open to Closed

Part of #11049

Also available in: Atom PDF