Bug report #10581

Composer - Draw map canvas items option

Added by Pedro Venâncio over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18987

Description

I have several Composer templates created in QGIS 2.2 that, when opened in master, appear with "Draw map canvas items" option unchecked.

Basically what happens is that as the "Draw map canvas items" option appears unchecked when opening a template created in an older version of QGIS, the map is printed in white. Grids, annotations, legend, etc., appears ok, but the content of canvas is blank.

If you open a new composer and add a new map, "Draw map canvas items" option appears selected, so opening old templates, the ideal was that this option also appear selected by default.

draw_map_canvas_items_1.jpg (274 KB) Pedro Venâncio, 2014-06-14 02:35 AM

draw_map_canvas_items_2.jpg (276 KB) Pedro Venâncio, 2014-06-14 02:35 AM

Planta_localizacao_2k_A3_3_QGIS2.qpt (27.6 KB) Pedro Venâncio, 2014-06-15 05:09 AM

Associated revisions

Revision 703ddb3d
Added by Nyall Dawson over 6 years ago

[composer] Loading old templates should default to drawing map canvas items (fix #10581)

History

#1 Updated by Nyall Dawson over 6 years ago

  • Status changed from Open to Closed

#2 Updated by Pedro Venâncio over 6 years ago

  • Assignee set to Nyall Dawson
  • Status changed from Closed to Reopened

Hi Nyall,

Thank you very much for the fix, but it seems that still does not solve. I just recompiled and the option remains unchecked for old templates.

Someone confirms?

#3 Updated by Nyall Dawson over 6 years ago

Can you please attach a sample template which demonstrates this issue?

#4 Updated by Pedro Venâncio over 6 years ago

Hi Nyall,

Yes, of course.

I've been watching and in .qpt file appears:

<ComposerMap keepLayerSet="false" overviewFrameMap="-1" id="0" previewMode="Cache" drawCanvasItems="false">

ie, the option is set to false.

The strange thing is that in QGIS 2.2 the map canvas is printed even with this option set to false. At this moment it seems to me that is the master who is acting correctly, no?

#5 Updated by Pedro Venâncio over 6 years ago

  • Status changed from Reopened to Closed

Hi Nyall,

I think the problem was not the one I mentioned here, so I will close this ticket and open a new one - #10599.

Also available in: Atom PDF