Bug report #10566

DB Manager : Impossible to add a geometryless table

Added by Harrissou Santanna over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:DB Manager
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18973

Description

Open DB Manager and connect yourself to a PostGIS database
Drag and drop a table or view without geometry column from the table list to the map canvas
You get a pop up saying that the layer you're trying to put in the canvas is not valid and won't be added.

The same table can be added through DB Manager in QGIS 1.8 but no more since 2.0.
The same table or view can though be added to the layer list when using Vector menu > Add PostGIS Layer in Master or previous.


Related issues

Related to QGIS Application - Bug report #8970: Failed import of csv table in DB Manager Closed 2013-10-31

Associated revisions

Revision 85ce6762
Added by Jürgen Fischer over 6 years ago

db_mananger: fix loading geometryless tables (fixes #10566)

History

#1 Updated by Jürgen Fischer over 6 years ago

  • Assignee set to Jürgen Fischer

#2 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Open to Closed

#3 Updated by Paolo Cavallini over 6 years ago

Any relation to #8970 ?

Also available in: Atom PDF