Bug report #10520

Wrong size of svg marker in point pattern fill (with data defined properties)

Added by zicke - over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18930

Description

The size of the svg marker changes only by panning from time to time. It should only change its size by zooming since an expression is used for the size of the marker:

CASE
WHEN $scale < 750 THEN 5.6
WHEN $scale >= 750 AND $scale < 1250 THEN 4
WHEN $scale >= 1250 AND $scale < 3000 THEN 2.8
WHEN $scale >= 3000 THEN 2
END

Testproject is attached (should look like attached screenshot).

svg_marker.png (129 KB) zicke -, 2014-06-10 03:47 AM

svg_marker.zip (294 KB) zicke -, 2014-06-10 03:47 AM

Associated revisions

Revision c49e38c3
Added by Martin Dobias over 6 years ago

Merge pull request #1449 from edigonzales/master

fixes #10520 (scale method for SVG) and #10509 (dash pattern)

History

#1 Updated by zicke - over 6 years ago

It seems that mScaleMethod in QgsSvgMarkerSymbolLayerV2::renderPoint() changes randomly. No idea why. And then the root is extracted.

#2 Updated by zicke - over 6 years ago

  • Pull Request or Patch supplied changed from No to Yes

#3 Updated by Martin Dobias over 6 years ago

  • Status changed from Open to Closed

#4 Updated by Martin Dobias over 6 years ago

  • Target version set to Version 2.4

Also available in: Atom PDF