Bug report #10466

Print Composer: Scalebar box vertically resizes itself after change to other Item elements

Added by kilo lima about 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.2.0 Regression?:No
Operating System:Fedora 21 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18878

Description

When adding a scalebar element to a map in the Print Composer, the default is that there is very little whitespace between the bottom of the scalebar and the border of the scalebar box. The user can adjust this to add space, but if another item box (such as legend, label, etc.) is adjusted on the page (such as moved or resized), the scalebar reverts to its original spacing and removes the whitespace. However, it doesn't always do this behaviour after every manipulation, it appears to be random.

It can be frustrating because if all the elements on a map have been carefully arranged to line up with each other, the sudden resizing of the scalebar box will look off, and sometimes it's not immediately apparent until after the final export.

I've noticed this issue since v 1.8.

default_scalebar_no_space_along_bottom.png - Default scalebar with very little space between bottom of scale and bottom border. Looks lopsided. (74.6 KB) kilo lima, 2014-06-04 03:11 PM

space_added.png - After adjusting the whitespace by manually dragging the lower side down to increase the space. (88.6 KB) kilo lima, 2014-06-04 03:11 PM

Associated revisions

Revision 4abaf60a
Added by Nyall Dawson over 5 years ago

[composer] Don't shrink scalebar height when updating

Previously any update of a scalebar would reset it's height to
the minimum height allowed. Now, if the user has set a height
greater than this minimum than that height is kept. (fix #10466)

History

#1 Updated by kilo lima about 6 years ago

Fedora 20, not 21.

#2 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF