Bug report #10237

project loads layers not seen in legend

Added by Regis Haubourg over 5 years ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18676

Description

Hi,
a user here produces qgs with more map layers than really existing in legend tree (24 in legend, with 59 maplayers)
I couldn't find a similar openened issue. See attached qgs file.
Version used is qgis 2.2. It is possible that issue comes from old 1.8 qgs file, but I can't be sure.
Anyway, QGIS should erase unused maplayers in qgs..
Régis

CouchesFantomessave2.qgs (788 KB) Regis Haubourg, 2014-05-12 08:31 AM

History

#1 Updated by Regis Haubourg over 5 years ago

attached qgs

#2 Updated by Giovanni Manghi over 5 years ago

we have also seen many times this issue: it seems that when removing layers form a project then sometimes the layers definitions are left inside the qgs file.

This is a serious issue and should be discussed in detail in the dev mailing list.

#4 Updated by Regis Haubourg over 5 years ago

Hi, this very annoying problem still remains. Several users are affected here. I think we can't let that to a normal priority, since there is no way cleaning the problem.

#5 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.4 to Future Release - High Priority

#6 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#7 Updated by Regis Haubourg over 1 year ago

  • Description updated (diff)
  • Status changed from Open to Feedback

Does anyone still see ghost layers in project files with 3.0?

#8 Updated by Giovanni Manghi over 1 year ago

Regis Haubourg wrote:

Does anyone still see ghost layers in project files with 3.0?

is this still true on 3.*?

#9 Updated by Regis Haubourg about 1 year ago

  • Status changed from Feedback to Closed

Not that I know of, let's close.

#10 Updated by Giovanni Manghi about 1 year ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF