Bug report #10234

Difficult to edit nodes of polygons close together

Added by Patrick Dunford almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:18673

Description

If I am editing a layer that contains polygons close together it can be almost impossible to select the one I am trying to edit, when the Node tool is being used.

In the picture shown I have four polygons. The red one and the grey one are in the same layer - the red one has been selected for node editing. Yet try as I might I simply cannot get its nodes to show the selection rectangle, no matter where I click. The majority of the time, the selection will snap to the other polygon next to this one.

I can't see why it is that if I have used the selection tool to select a particular polygon, why I can't make the vertices of that polygon be selected for editing. Even when I click in the bottom right corner I am still selecting a vertice on the polygon in the top left hand corner !

All the snapping options have been looked at and tolerances set to zero but still getting the problem.

qgis_bug_2014-05-12.JPG (98.6 KB) Patrick Dunford, 2014-05-12 12:43 AM

Third_Floor.zip (29.8 KB) Patrick Dunford, 2014-05-12 03:49 AM

qgis_bug_2014-05-12a.JPG (687 KB) Patrick Dunford, 2014-05-13 04:06 AM

qgis_IMG_0770.jpg (492 KB) Patrick Dunford, 2014-05-20 06:57 AM


Related issues

Related to QGIS Application - Feature request #11022: Difficult to modify nodes of contiguous polygons Closed 2014-08-07
Related to QGIS Application - Feature request #3752: Clicking inside the polygon with the Node tool Open

History

#1 Updated by Patrick Dunford almost 6 years ago

Sample project and layers attached.

#2 Updated by Patrick Dunford almost 6 years ago

And another thing, I want someone to tell me what is happening here because this is incredibly frustrating as well... I have clicked on one vertice (node) and it decides to move two instead of one. This happens sometimes quite often regardless.

#3 Updated by Antonio Locandro almost 6 years ago

Sorry, I don't see the red square but I am not able to confirm what you report, to edit nodes and select you have to click on the appropriate layer in the list of layers, I could move the nodes without issues and I couldn't reproduce.

#4 Updated by Patrick Dunford almost 6 years ago

Uh??? Well here is another illustration. I have used the selection tool to select the polygon which is filled with red (the selection colour of my project). I now try to click on the top right corner (node) of that polygon. Instead of that, what is being selected is the line shown in blue which is the side of a different polygon.

At the least it should be possible to select the nodes of the currently selected polygon, if there are several which are close together.

#5 Updated by Patrick Dunford almost 6 years ago

The photo that was supposed to accompany the last submission.

#6 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback
  • Category set to Digitising

Patrick Dunford wrote:

Uh???

the project you attached is missing two layers that are probably necessary to understand better your point. A screencast would also probably help.

#7 Updated by Leyan Ouyang almost 6 years ago

Patrick Dunford wrote:

And another thing, I want someone to tell me what is happening here because this is incredibly frustrating as well... I have clicked on one vertice (node) and it decides to move two instead of one. This happens sometimes quite often regardless.

This happens if you click on the segment instead of the node. Then both extremities of the segment are selected and moved together. I often do that by mistake as well, I agree the UI is not very good.

#8 Updated by Leyan Ouyang almost 6 years ago

I had a look at your shapefiles and I can't reproduce the issue. I agree with Giovanni that a screencast would be very useful to see where is the problem.

edit: I think I see your problem: when a polygon has already been selected, you cannot select another one by clicking "too close" of the first one. However, this "too close" is not affected by the zoom, so can give counter-intuitive results. I will look into it.

#9 Updated by Leyan Ouyang almost 6 years ago

The issue is due to rounding happening when selecting features and snapping nodes.

In the short term, I would advise to choose a projected coordinate refrence system instead of WGS84 to work on such large scale data. This should solve your problems as you would be working in meters instead of degrees, giving more reasonable numbers to work with. If it is not possible, try to zoom out when selecting new features and nodes, this will help a bit.

However, I agree that there are bugs in the way QGis deals with these level of zoom and and these small distances. If they are available, all QGis features should work as expected.

#10 Updated by Patrick Dunford almost 6 years ago

Thanks that last response.
If the layers you get come in WGS84 coordinates, how do you change the coordinates into some other system?

#11 Updated by Giovanni Manghi almost 6 years ago

Patrick Dunford wrote:

Thanks that last response.
If the layers you get come in WGS84 coordinates, how do you change the coordinates into some other system?

activate the reprojection in project properties and select a cartographic CRS, or use the "save as..." function to create copies of your layers in a projected CRS.

I would suggest to close this ticket.

#12 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to worksforme

Closing for lack of feedback.

#13 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF