Bug report #10177

Field expression control keeps jumping to end of text

Added by Nyall Dawson over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:Denis Rouzaud
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18631

Description

If I try and edit an expression in the new field expression control, the cursor keeps jumping to the end of the line of text. I think this happens when the expression is deemed invalid, but it makes it nearly impossible to edit an expression as it's likely to be invalid when I'm only mid-way through the edit.

History

#1 Updated by Denis Rouzaud over 6 years ago

I am facing troubles to resolve this one...
The problem is that editing text will change the model...and changing the model resets the combo thus changing the line edit...

no idea on how to solve this yet...

#2 Updated by Denis Rouzaud over 6 years ago

  • Status changed from Open to Closed

ok, this has been solved by not sending expression to the model at each key press.
instead the expression is sent when editing is finished, thus the cursor remains.

thanks Nyall for your suggestion!

#41ccfb913264859f0490ee1c60b664bb4fadde9e

Also available in: Atom PDF