Bug report #10171

Layer "Save as" dialog suggests wrong CRS is used

Added by Johannes Kroeger over 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:all Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18625

Description

The "Save as" dialog of a layer is misleading.

1. Load a WGS84 layer (I used a random shapefile).
2. In the Project Properties enable OTF reprojection and select a different CRS (I used EPSG 25832).
3. Right-click the layer and "Save as..."
4. Select "Project CRS". See the attachment for what the dialog now looks like. It suggests that EPSG 4326 will be used by displaying that in the grey field.
5. Press "OK" to save, it will actually save correctly as EPSG 25832.

I assume the greyed out field is only used for "selected CRS" because when that option is selected, it becomes white (not editable though?).
I would suggest displaying the CRS that will be used in that field. Leave it grey all the time. Alternatively not displaying that field at all unless "selected CRS" is selected.

misleadingsaveasdialog.png (19.3 KB) Johannes Kroeger, 2014-05-04 08:23 AM

History

#1 Updated by Anita Graser over 6 years ago

  • Operating System changed from Linux to all
  • Category set to GUI

#2 Updated by Nyall Dawson almost 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in master

Also available in: Atom PDF