Bug report #10156

When using SVG fill an odd expression is added to data defined properties -> border width

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18613

Description

In QGIS 2.0.1, 2.2 and master open a polygon vector, make an svg fill and save project.

Reopen project and go to data defined properties.

The border width parameter is filled with an odd expressions

svgOutlineWidth_expression

that result as invalid when opening the expression builder.

It does seems harmless but anyway is a bug.

Associated revisions

Revision 43e1a635
Added by Nyall Dawson over 6 years ago

Fix invalid data defined parameters for SVG fill after loading project (fix #10156)

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Target version set to Version 2.4
  • Priority changed from Normal to Severe/Regression

This is directly linked to #10153

because it is the presence of this expression that makes qgis crash if a svg fill is missing.

#2 Updated by Nyall Dawson over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF