Bug report #10140

no dropdown in Vector>Research>Random Points>Use value from input field

Added by Paul Ramsey over 5 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18599

Description

Trying to generate a dot map, using the Random Points feature and an input column to control the number of points, I find that the relevant drop-down in the dialogue does not display any field options.

Associated revisions

Revision b2ca6d02
Added by Alexander Bruy almost 4 years ago

[fTools] correctly handle real fields in Random Points algorithm (fix #10140)

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Affected QGIS version changed from 2.2.0 to master
  • Category changed from Vectors to 44
  • Priority changed from High to Severe/Regression
  • Target version changed from Version 2.2 to Version 2.4
  • Operating System deleted (OSX)
  • OS version deleted (10.7)

confirmed (on Linux and Windows), and it is a regression.

#2 Updated by Alexander Bruy over 5 years ago

  • Status changed from Open to Feedback
  • Tag deleted (random points)

Not reproducible here. Maybe your shapefile does not have any field with "integer" datatype?

#3 Updated by Paul Ramsey over 5 years ago

You can tell I'm a programmer, because that's the first thing I thought. I did have a file full of reals, so I made one with integers, and still no go. I'd hope that the system would not be too pedantic to use real number inputs though.

#4 Updated by Giovanni Manghi over 5 years ago

Hi Alex,

I have also tested shapes and postgis with integer columns and no joy. Weird.

#6 Updated by Giovanni Manghi over 5 years ago

  • Priority changed from Severe/Regression to Normal

On QGIS master the tool in the vector menu seems to work now with shapes and integer columns, but seems also that integer postgis columns are not recognized.

On the other hand the same tool in the processing toolbox works as expected, so I guess that the priority of this ticket can be lowered.

#7 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Open

#8 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.4 to Future Release - High Priority

#9 Updated by Alexander Bruy almost 4 years ago

  • Status changed from Open to Closed

#10 Updated by Alexander Bruy almost 4 years ago

  • Resolution set to fixed/implemented

#11 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF