Bug report #10137

Processing stripping out +towgs params

Added by Paolo Cavallini over 5 years ago. Updated 10 months ago.

Status:Open
Priority:High
Assignee:-
Category:Processing/GRASS
Affected QGIS version:3.4.1 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18596

Description

Apparently Processing, during the analyses starting from layers in a CRS with +towgs parameters (e.g. 23030) creates outputs with a similar projection, but without the parameters; a custom CRS is thus created, and the output does not align with the input.
This happens at least with GRASS and R backends.


Related issues

Related to QGIS Application - Bug report #11884: Processing generates outputs with no "+towgs84" parameters Closed 2014-12-18
Duplicated by QGIS Application - Bug report #17494: v.clean and v.clean advanced tools return cleaned layers ... Closed 2017-11-19

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Affected QGIS version changed from 2.2.0 to master
  • Priority changed from Normal to Severe/Regression
  • Target version set to Version 2.4

Confirmed here on master/ubuntu.

This is certainly a regression.

PS
It does not happen only for CRSs that may exist in two version, one with towgs84 and one not (ex: 3003 and 102091), but happens with all CRSs: in one original CRS has no equivalent version without towgs84 then the result will be a layer with a custom CRS automatically created by qgis.

#2 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to Feedback

Can you please check again, it does not seems to happen anymore.

#3 Updated by Paolo Cavallini over 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Confirmed, it is OK here

#4 Updated by Giovanni Manghi over 4 years ago

  • Category changed from 94 to Processing/Core

#5 Updated by leolami - over 2 years ago

  • Affected QGIS version changed from master to 2.14.11
  • Status changed from Closed to Reopened
  • Target version changed from Version 2.4 to Version 3.0
  • Operating System set to Windows

Hi all,
the problem is again present on the GRASS modules
QGIS 2.14.11 on Windows 10 but I think also in Linux

For example v.select

Regards

#6 Updated by Giovanni Manghi over 2 years ago

see also #11884

#7 Updated by Giovanni Manghi over 2 years ago

  • Operating System deleted (Windows)
  • Affected QGIS version changed from 2.14.11 to 2.18.4
  • Resolution deleted (fixed/implemented)
  • Target version changed from Version 3.0 to Version 2.18
  • Category changed from Processing/Core to Processing/GRASS

#8 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#9 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#10 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#11 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from 2.18.4 to 2.18.7
  • Description updated (diff)
  • Status changed from Reopened to Open

#12 Updated by Giovanni Manghi about 2 years ago

  • Affected QGIS version changed from 2.18.7 to 2.18.10

#13 Updated by Giovanni Manghi about 2 years ago

  • Affected QGIS version changed from 2.18.10 to 2.18.11

#14 Updated by Jürgen Fischer almost 2 years ago

  • Duplicated by Bug report #17494: v.clean and v.clean advanced tools return cleaned layers with CRSs other than the CRSs of the input layers added

#15 Updated by Paolo Cavallini over 1 year ago

  • Assignee deleted (Victor Olaya)

#16 Updated by Giovanni Manghi over 1 year ago

  • Affected QGIS version changed from 2.18.11 to 3.0.0

#17 Updated by Giovanni Manghi about 1 year ago

  • Affected QGIS version changed from 3.0.0 to 3.3(master)

#18 Updated by Alexandre Neto 10 months ago

  • Affected QGIS version changed from 3.3(master) to 3.4.1

Also available in: Atom PDF