Bug report #10107

OGR vector layer w/ protocol GeoJSON vanishes and gives OGR Error 4 when transformed

Added by Sfkeller - over 6 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/OGR
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:18575

Description

These are the steps to reproduce the error:

1. Add "New Vector Layer..." with protocol GeoJSON (= OGRGeoJSON, set to EPSG:4326):
Example: http://tools.wmflabs.org/wiwosm/osmjson/getGeoJSON.php?lang=de&article=Hombrechtikon
=> GeoJSON is being displayed.

2. Set to any different CRS, like opening "Project > Options" and enable "CRS transformation":
=> OGRGeoJSON layer isn't displayed anymore
=> and puts following error into protocol/log: "OGR3 Error 4: GeoJSON Driver doesn't support update".

History

#1 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.2 to Future Release - Lower Priority

#2 Updated by Jürgen Fischer about 5 years ago

  • Category changed from Data Provider to Data Provider/OGR

#3 Updated by Even Rouault almost 4 years ago

  • Status changed from Open to Feedback

The "http://tools.wmflabs.org/wiwosm/osmjson/getGeoJSON.php?lang=de&article=Hombrechtikon" URL no longer responds. Any way to reproduce this issue ?

#4 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF