Bug report #10084

Legend does not display correct symbol in the composer when the size of the marker is changed

Added by Frédéric Parrenin over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:18552

Description

See attached screenshot to understand the problem.
In the legend, the Vittuari et al. (2004) dataset should be displayed with an arrow but it is displayed with a dot.
This happens because I changed the size of the marker to '0.2' instead of '1'.

Qgis-legend-bug.png (124 KB) Frédéric Parrenin, 2014-04-17 02:21 AM

Sans_nom_1.png (145 KB) Frédéric Parrenin, 2014-04-18 05:48 AM

History

#1 Updated by Nyall Dawson over 6 years ago

  • Status changed from Open to Feedback

How are you setting the size of the arrows in your layer? Is it via data defined symbology?

#2 Updated by Frédéric Parrenin over 6 years ago

To change the symbol size, I go to the layer properties > Style > size

#3 Updated by Nyall Dawson over 6 years ago

I'm still confused - in your image the arrows have varying styles. How are you controlling this varying size of arrows in your project? If it's via data defined symbology or via the "advanced"->"size scale field" then this is a known issue with legends...

#4 Updated by Frédéric Parrenin over 6 years ago

I control the varying size and orientation of the arrows with the "advanced" button.
But if I keep unchanged the size, there is no problem with the legend.
See attached screenshot.

#5 Updated by Nyall Dawson over 6 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Duplicate of #4450

Also available in: Atom PDF