Bug report #10065

QGIS 2.2 Attribute Editor Layout “Drag and Drop designer” Field does not exist in datasource

Added by Jan Van Bennekom-Minnema over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Matthias Kuhn
Category:-
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18541

Description

During experimenting with QGIS version 2.2 "Relations" where Foreign Key relations from a database can be documented, so that the QGIS UI can (auto) generate its Attribute Editor Layout in Master-Detail / Parent-Child forms. See http://gis.stackexchange.com/questions/91991, there seems to be a bug with DragAndDrop attribute editor layout, an error message "Error: Field does not exist in datasource" appears in the place of the detail layer/relation.

Associated revisions

Revision 35de393d
Added by Matthias Kuhn over 5 years ago

Correctly load dnd relations in fields properties
Fix #10065

History

#1 Updated by Julien Perrot over 5 years ago

  • Target version set to Version 2.2

More information about it :
- The first time the relation is added to the form, it's correctly saved in the project (as a "attributeEditorRelation" in the XML)
- Then if we save again the properties of the cocnerned layer, an error apperaed (it's transformed into a "attributeEditorField", with bad index and name in the XML)

#2 Updated by Marianne Aubert over 5 years ago

  • Assignee set to Matthias Kuhn

#3 Updated by Paolo Cavallini over 5 years ago

Confirmed here on current master.

#4 Updated by Matthias Kuhn over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF