Bug report #9902

Using v.voronoi with "output tessellation as graph" returns point result

Added by Anita Graser over 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Giovanni Manghi
Category:Processing/GRASS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18416

Description

While the GUI suggests that the output will be lines, the tool actually returns points.

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Affected QGIS version set to 2.4.0
  • Crashes QGIS or corrupts data set to No
  • Project changed from 78 to QGIS Application
  • Category deleted (59)

#2 Updated by Giovanni Manghi almost 6 years ago

  • Category set to Processing/GRASS

#3 Updated by Giovanni Manghi over 5 years ago

  • Assignee changed from Victor Olaya to Giovanni Manghi
  • Affected QGIS version changed from 2.4.0 to master
  • Target version set to Future Release - Lower Priority

The reason for this is that the line output is written by GRASS into the 0_ layer and not the 1_ layer that is the one that Processing exports.
The solution (used also for other cases like this one) is to add a special case in the routine that exports the vector outputs.

#4 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to In Progress

#5 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from In Progress to Closed

Also available in: Atom PDF