Bug report #9895

In python console, input() raises EOFError

Added by pierre krmr over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:18412

Description

Just type "input()" in the Qgis console :


input()
Traceback (most recent call last):
File "<input>", line 1, in <module>
EOFError: EOF when reading a line

What it should do :


input()
then i type something + enter
'then i type something + enter'

I need it for a script to ask the user for some string data (like Y/N choices, new parameters depending on partial results after a first process step, etc...)


Related issues

Duplicates QGIS Application - Bug report #9894: In python console, input() raises EOFError Closed 2014-03-26

History

#1 Updated by Anita Graser over 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #9894

Also available in: Atom PDF