Bug report #9880

Wrong feature order after commiting changes

Added by Piotr Pociask over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:18401

Description

Steps to reproduce:

1. Start editing vector layer.
2. Add two or more new features.
3. Stop editing and save changes.

New features are added at the end of layer but in reversed order of digitalization. This is present in QGIS 2.0, 2.2. and master (Win7 and Mint 15). Features should be saved in order of addition.
This is also present if features are added from Python addFeature method of QgsVectorLayer.

History

#1 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Feedback

By the term "order", are you referring to rendering order?

In general:
There is no implicitly defined order of features on a layer. If you need a specific order (for any reason), you have to define an attribute for it.

#2 Updated by Jürgen Fischer over 6 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

closing for the lack of feedback - looks like a non-issue anyway.

Also available in: Atom PDF