Bug report #9796

cpt city ramps missing when using --configpath startup option

Added by Regis Haubourg over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Symbology
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18336

Description

Hi,
when using -- configpath option to move profiles to a centralized network storage, cpt city ramps do not show in cpt city browser.
Confirmed on windows 7 and server 2008, with QGIS 2.2 64 + QGIS master

History

#1 Updated by Etienne Tourigny over 5 years ago

  • Assignee set to elcuco -

can you test this on linux?

#2 Updated by Etienne Tourigny over 5 years ago

  • Assignee deleted (elcuco -)

#3 Updated by Regis Haubourg over 5 years ago

Not at the moment, I must mount a virtual machine.. I tested on Macos, QGIS 2.0 works fine, but I couldn't upgrade to 2.2.. my Mac is too old :-(((
Anyone can test ?

#4 Updated by Etienne Tourigny over 5 years ago

for me it works under linux when starting qgis like this

qgis --configpath /tmp/qgis

note that the given directory is empty, never tried this before

#5 Updated by Regis Haubourg over 5 years ago

Is the target directory still empty after you close Qgis. You should find in it all QGis db's and ini files at least. If not startup option did not work..

#6 Updated by Etienne Tourigny over 5 years ago

The cpt-city ramps were not copied, but I can see them even if I start qgis with same arguments.

I don't know if they should be copied over, or if there is a bug with finding the path of system-wide installation of cpt-city ramps in Windows.

Here are the contents

[email protected]: /data/research/work/inland/hg/inland-current/output $ ls -lR /tmp/qgis/
/tmp/qgis/:
total 124
drwx------ 4 tourigny tourigny  4096 Mar 18 13:49 cache
drwx------ 2 tourigny tourigny  4096 Mar 18 13:49 gdal_pam
drwx------ 5 tourigny tourigny  4096 Mar 18 13:50 processing
drwx------ 2 tourigny tourigny  4096 Mar 18 13:49 QGIS
-rw-r--r-- 1 tourigny tourigny 23552 Mar 18 13:49 qgis.db
-rw-r--r-- 1 tourigny tourigny 84992 Mar 18 13:50 symbology-ng-style.db

#7 Updated by Regis Haubourg over 5 years ago

Well, they don't have to be copied in the roaming profile, this looks like a problem reading path ..

#8 Updated by Regis Haubourg over 5 years ago

Issue is still here and seems related to using UNC path, or dot in file name for profile displacement.
Using --configpath "F:\\Outils\\QGISDEV\\CONF_QGIS_MASTER" works when
--configpath "\\\\NAS01\\appdata2008\\%username%\\AppData\\Roaming\\.qgis2" does not show cpt city color ramps in ctp city browser

#9 Updated by Regis Haubourg over 5 years ago

mmm, when moving to a new empty profile, using UNC path like --configpath "\\\\NAS01\\appdata2008\\%username%\\AppData\\Roaming\\.qgis24" it now works...

#10 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.4 to Future Release - High Priority

#11 Updated by Jürgen Fischer about 5 years ago

  • Status changed from Open to Closed

Looks like it was a problem with the remote config.

Also available in: Atom PDF