Bug report #979

disable "move vertex" tool editing points layer

Added by Maciej Sieczka - over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11038

Description

As the title reads. The "move feature" tool is enough for points. Having 2 tools doing the same confuses the user.

History

#1 Updated by Maciej Sieczka - over 12 years ago

Still valid as of b5286872 (SVN r8353).

#2 Updated by Marco Hugentobler over 12 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

fixed in b21a661a (SVN r8364)

#3 Updated by Maciej Sieczka - over 12 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

I just tried with an empty PostGIS multipoint layer and both tools are still active in digitizer. If there is at least one point it's OK though.

What's wrong?

#4 Updated by Marco Hugentobler over 12 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

This is intended behaviour. The tool is only disabled for point layers. It is enabled for multipoint layers to allow for the possibility to move only one point of a multipoint feature.

#5 Updated by Maciej Sieczka - over 12 years ago

Ah, well thought.

However, I can see that both tools are enabled for simple point layers as well. Does it have to?

Also, the "Move vertex" remains selectable even after I quit digitizer.

#6 Updated by Marco Hugentobler over 12 years ago

Oh, you are right, there is still a bug.
Please try if it works now in .

#7 Updated by Maciej Sieczka - over 12 years ago

All OK now!

#8 Updated by Anonymous about 11 years ago

Milestone Version 0.9.2 deleted

Also available in: Atom PDF