Bug report #9759

rectangular polygons displayed as triangles in QGIS 2.2

Added by Olav Peeters over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:18305

Description

see attached sample file.
In QGIS versions prior to 2.2 this .shp will be displayed as a set of rectangular polygons. In QGIS 2.2 (I tested this on Windows 7 and MacOSX 10.9, same result), this set of rectangular polygons is displayed as a set of triangles. This has also been signaled by another QGIS user: http://gis.stackexchange.com/questions/88723/qgis-2-2-geometry-error

error_qgis_render_rec_polygons.zip (5.84 KB) Olav Peeters, 2014-03-11 03:34 AM


Related issues

Related to QGIS Application - Bug report #9686: Geometry simplification bug with grid layer Closed 2014-03-02

History

#1 Updated by Matthias Kuhn over 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #9686 which has been fixed (fix will be included in the next release).

As a temporary workaround disable rendering simplification in the layer properties.

Also available in: Atom PDF