Bug report #9733

GPS/KML/WFS load with empty attribute table in qgis master and 2.2 (is ok on 2.0.1)

Added by Giovanni Manghi over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18286

Description

subject says it all

Note added:

This happens only when the "show selected features" or "shows features visible on map" acre active in QGIS general properties, so the issue is less bad than supposed, but still a regression.

Associated revisions

Revision f97fa90c
Added by Martin Dobias about 6 years ago

Fix #9733 (empty attribute table if showing just selected / visible features)

History

#1 Updated by Filipe Dias over 6 years ago

This is terrible...is there any workaround? For those who work with GPS devices and Google Earth on a daily basis it would be extremely important to have some way of accessing the attributes table.

#2 Updated by Stefan Blumentrath over 6 years ago

Hi Giovanni and Filipe,
I just checked on QGIS 2.2.0 (commit:1c3699e) installed on Win7 through OSGeo4W (32bit). There I could not reproduce the problem with GPX (did not test KML).
Both import and export work for me with attribute table...
Maybe encoding related? I used latin4...
S

#3 Updated by Giovanni Manghi over 6 years ago

This happens only when the "show selected features" or "shows features visible on map" acre active in QGIS general properties, so the issue is less bad than supposed, but still a regression.

#4 Updated by Giovanni Manghi over 6 years ago

  • Subject changed from gpx and kml load with empty attribute table in qgis master and 2.2 (is ok on 2.0.1) to GPS/KML/WFS load with empty attribute table in qgis master and 2.2 (is ok on 2.0.1)

It affects also WFS layers.

#5 Updated by Martin Dobias about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF