Bug report #9662

label set to curved placement are broken when rendering onto a map item in the qgis composer

Added by Mathieu Pellerin - nIRV about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Martin Dobias
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18229

Description

Under qgis master (2.3), labels that are set to curved placement fail to render properly onto map items in the qgis composer (but are ok on the main qgis map canvas), see label_curve_broken.png.

Steps to reproduce:
1. load the label_curve_broken project attached to this issue
2. Look at the proper rendering of the curved label on the main canvas
3. Open the qgis composer
4. Make sure the map item is set to cache preview
5. Notice how the curved label is rendered improperly: the letters are too close to each other
6. Changing the composer zoom level will affect the (wrong) spacing between letters of the curved label too

label_curve_broken.png (160 KB) Mathieu Pellerin - nIRV, 2014-02-26 12:21 AM

label_curve_broken.zip (9.22 KB) Mathieu Pellerin - nIRV, 2014-02-26 12:21 AM

History

#1 Updated by Martin Dobias about 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also seems to be fixed by daf1e0b6881cdb77df6f6a9dc988ad92e0f9019d (for #9661)

Also available in: Atom PDF