Bug report #9656

Scroll bar missing from python log messages.

Added by Donovan Cameron about 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18224

Description

I just got a large python error message from a plugin when qgis started.

Noticed the scrollbar on the right is missing for the python tab on the Log Messages panel. Had to copy and paste error msg into text editor to be able to see the entire thing.

But that also means, I can only copy and paste the 1st log message about python, and have to use up/down arrow keys to look for other messages.

Looks like the scrollbar could probably be added to the python tab in the log messages panel.

windows_python_scroll.png - showing missing scrollbar for python messages in log panel (15.1 KB) Donovan Cameron, 2014-03-01 08:58 AM

Associated revisions

Revision 7581370b
Added by Salvatore Larosa almost 6 years ago

Fixes #9656 - allows to scroll per pixel vertically in the log messages tabs

History

#1 Updated by Donovan Cameron about 6 years ago

This is on Linux 64-bit, Arch.

#2 Updated by Giovanni Manghi about 6 years ago

  • Target version set to Version 2.4
  • Status changed from Open to Feedback

as for the other similar ticket I cannot confirm or I'm looking at the wrong place.

#3 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.4 to Future Release - High Priority

#4 Updated by Donovan Cameron about 6 years ago

Here's the screen from Windows 8.1 64bit (OSGeo4W) showing the missing scroll-bar in Python tab for the log messages panel.
The message from python is different in Linux, but I don't see a scroll bar there either.

#5 Updated by Giovanni Manghi about 6 years ago

  • Status changed from Feedback to Open
  • Target version changed from Future Release - High Priority to Future Release - Lower Priority

ok, cannot confirm on both Mint (Cinnamon DE) and Windows 7.

#6 Updated by Salvatore Larosa almost 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF