Bug report #9644

WMS and CRS - No reprojection

Added by Lene Fischer over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18216

Description

When I set a CRS to 25832 and open a vectorfile in 4326 - it is not reprojected.
If I open a WMS and choose 25832 - as set in Settings>Options>CRS
it is twisted as in 4326.

Then I close both layers.

Start to open first WMS with EPSG:25832 – Also trying to click on ‘Change’ to be sure – But the map remain twisted in EPSG:4326.

I have to restart the program to get the projection right.

The WMS also have become very slow –

Regards
Lene Fischer

mdc_sample_table-shp__1_.zip (1.44 KB) Lene Fischer, 2014-02-27 09:43 PM

24.png (293 KB) Giovanni Manghi, 2014-02-28 06:10 AM

Associated revisions

Revision 3b4edb8f
Added by Jürgen Fischer over 5 years ago

automatic otfr:
  • notify on message bar when CRS and OTFR kicks in (refs #9644)
  • don't automatically change settings of loaded projects

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 2.2 to Version 2.4
  • Status changed from Open to Feedback
  • Priority changed from High to Normal

Hi,

I'm sorry but the description is not clear to me and I'm unable to try replicate the issue.

Can you add clear steps and eventually (better) a project that included all the necessary data? thanks

#2 Updated by Lene Fischer over 5 years ago

Hi Giovanni,
Please see the attached video. http://screencast.com/t/YTUllDTl9bcz
Also attach the vectorlayer
WMS : http://kortforsyningen.kms.dk/?servicename=topo_skaermkort&client=QGIS&version=1.1.1&login=Lene_Fischer&password=blomst

The same error was in 2.0 - but not in the weekly since last summer.

Regards
Lene

#3 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to invalid
  • File 24.png added
  • Status changed from Feedback to Closed

Lene Fischer wrote:

Hi Giovanni,
Please see the attached video. http://screencast.com/t/YTUllDTl9bcz
Also attach the vectorlayer
WMS : http://kortforsyningen.kms.dk/?servicename=topo_skaermkort&client=QGIS&version=1.1.1&login=Lene_Fischer&password=blomst

The same error was in 2.0 - but not in the weekly since last summer.

Regards
Lene

Hi,

it is not a bug, it all depends on how you have configured qgis in

settings -> crs -> default crs for new projects

in your case it should be as is in the attached image. This means that you say to qgis to create a new project in WGS84 and then automatically reproject any layer in this CRS.

If you want the first layer give its CRS to the project then choose the second option.

#4 Updated by Lene Fischer over 5 years ago

  • Status changed from Closed to Reopened

Hi iovanni,
I´ve set the settings to be 25832 (UTM 32) - Start New projects in UTM 32
I´ve set on the fly to set CRS to UTM 32 - but it keep staying in WGS84.
Regards
Lene

#5 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Reopened to Closed

Lene Fischer wrote:

Hi iovanni,
I´ve set the settings to be 25832 (UTM 32) - Start New projects in UTM 32
I´ve set on the fly to set CRS to UTM 32 - but it keep staying in WGS84.

Hi Lene,

at 00:42 of your screencast you can see clearly that when you create a new project, the project CRS is 4326 and the OTFR in ON. Have a look to the right bottom corner of the main QGIS window, it says 4326 and the text is black (means OTFR is on).

cheers!

#6 Updated by Lene Fischer over 5 years ago

Exatly this is my problem. I set the CRS to UTM 32 in settings I set the On the fly to UTM 32 and the it changes to WGS84.
I am not able to get the projection to UTM 32 - Only to close the porgram and open the WMS first and the open the vectorlayer.

Regards
Lene

#7 Updated by Giovanni Manghi over 5 years ago

Lene Fischer wrote:

Exatly this is my problem. I set the CRS to UTM 32 in settings I set the On the fly to UTM 32 and the it changes to WGS84.
I am not able to get the projection to UTM 32 - Only to close the porgram and open the WMS first and the open the vectorlayer.

Regards
Lene

In the video at 00:42 is not clear what you do: do you click "new project" or use the ctrl-n shortcut? or do you simply remove the layers from the project?

#8 Updated by Lene Fischer over 5 years ago

I click "new project"

#9 Updated by Giovanni Manghi over 5 years ago

Lene Fischer wrote:

I click "new project"

just tested again (under Windows) and no problems.

Check again your

settings -> crs -> default crs for new projects

to be sure that is set to "enable reprojection by default" and the CRS is 25832

If it still fails try removing the .qgis2 folder, and see if removing all configs/plugins it works.

#10 Updated by Lene Fischer over 5 years ago

  • Status changed from Closed to Reopened
  • Target version changed from Version 2.4 to Version 2.2

Please take this seriously! What am I doing wrong?
Default CRS for new projects:
I have a new project - CRS set to UMT32 EPSG 25832.
Settings "Automatic enable on the fly projections if layers has different CRS" set to EPSG 25832.

When I open a vectorfile i EPSG 4326 the project is changed to this projection - My setting is overruled.
When I open a WMS - in EPSG 25832 - then this is reprojected to EPSG 4326.

Regards
Lene

#11 Updated by Giovanni Manghi over 5 years ago

Lene Fischer wrote:

Please take this seriously! What am I doing wrong?

I'm taking it very seriously, sorry if you feel that I'm not, that wasn't my intention.

Default CRS for new projects:
I have a new project - CRS set to UMT32 EPSG 25832.
Settings "Automatic enable on the fly projections if layers has different CRS" set to EPSG 25832.

the option

"Automatic enable on the fly projections if layers has different CRS"

does not work as you are expecting.

If you have this option selected and you add a layer in a empty project, then the project is given the CRS of the layer.

To get what you expect you must select

"enable OTRF by default"

When I open a vectorfile i EPSG 4326 the project is changed to this projection - My setting is overruled.

see above

When I open a WMS - in EPSG 25832 - then this is reprojected to EPSG 4326.

yes, because meanwhile the project has changed CRS to wgs84 (the CRS of the vector) and OTFR was enabled. So when you add a new layer this is reprojected in project CRS (but its CRS is still the one you selected, 25832).

Make sense now?

#12 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Reopened to Feedback

#13 Updated by Giovanni Manghi over 5 years ago

When I open a vectorfile i EPSG 4326 the project is changed to this projection - My setting is overruled.
When I open a WMS - in EPSG 25832 - then this is reprojected to EPSG 4326.

fyi 3b4edb8fa8b14c3fb2f37a825c5771b76b60b6f3

#14 Updated by Jürgen Fischer about 5 years ago

  • Status changed from Feedback to Closed
  • Resolution changed from invalid to fixed/implemented

closing for the lack of feedback - probably solved.

Also available in: Atom PDF