Feature request #9639

Keep CRS when saving DXF files

Added by Novarese   over 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DXF export
Pull Request or Patch supplied:No Resolution:
Easy fix?:No

Description

Qqis 2.2.0 by Osgeo, under Win7_x64

If you save something as DXF (setting any output CRS) and you load the .DXF file back in an empty project, the CRS is not kept.

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Category set to Vectors
  • Status changed from Open to Feedback
  • Target version set to Version 2.4

as far as I know the DXF format does not store any info about the CRS/SRID.

#2 Updated by Jürgen Fischer over 3 years ago

  • Target version changed from Version 2.4 to Future Release - High Priority

#3 Updated by Novarese   over 3 years ago

_Giovanni Manghi wrote:

as far as I know the DXF format does not store any info about the CRS/SRID._

 

@ Giovanni

Fortunatamente lo conserva:
http://novarese.t15.org/gfoss/elba_32632.zip

Se apri questo DXF nel Blocco Note e cerchi la stringa "UTM", esso è pienamente georiferito: come controprova, caricalo nella trial di Autocad Map, poi dai il comando _ADESETCRDSYS...

Il problema è che Qgis non ingloba alcun SR nei DXF, nonostante richieda di specificarlo durante il salvataggio...

@ rest of the world

Luckily it stores it:
http://novarese.t15.org/gfoss/elba_32632.zip

If you open up this DXF in Notepad and look for "UTM" string, it's fully georeferenced: as countercheck, load it in the Acadmap trial, then type the _ADESETCRDSYS command...

The issue is that Qgis does NOT embed any CRS within DXFs, even if it needs to specify it upon "saving as"...

#4 Updated by Jürgen Fischer over 3 years ago

Novarese   wrote:

Luckily it stores it:
http://novarese.t15.org/gfoss/elba_32632.zip

If you open up this DXF in Notepad and look for "UTM" string, it's fully georeferenced: as countercheck, load it in the Acadmap trial, then type the _ADESETCRDSYS command...

The issue is that Qgis does NOT embed any CRS within DXFs, even if it needs to specify it upon "saving as"...

Well, applications (like Map) may save all kinds of data in custom dictionaries. The DXF spec doesn't mention ADE_PROJECTION. Do you know any spec that could help with mapping ADE_PROJECTION codes to EPSG codes and vice versa?

#5 Updated by Giovanni Manghi almost 3 years ago

  • Tracker changed from Bug report to Feature request
  • Subject changed from Saved DXF doesn't keep the CRS to Keep CRS when saving DXF files
  • Category changed from Vectors to DXF export
  • Status changed from Feedback to Open
  • Target version changed from Future Release - High Priority to Future Release - Nice to have

#6 Updated by Jürgen Fischer almost 3 years ago

  • Status changed from Open to Closed

closing for the lack of feedback

Also available in: Atom PDF