Bug report #9635

Qgis 2.2 install on ubuntu wiped projection information

Added by Heather Hillers over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18207

Description

I installed qgis 2.2 this morning from ubuntugis-unstable on ubuntugis-precise. I formerly had 2.1 installed from ubuntugis

The install gave the following suspicious Output:

qgis-providers-common (2.0.1-2+precise1) wird eingerichtet ...
Synchronizing CRS database with GDAL/PROJ definitions.
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
Loading epsg.wkt
0 WKTs loaded
CRS update (inserted:0 updated:0 deleted:3631 errors:0)
No CRS updates were necessary.

And although qgis 2.2 installed fine, all the commonly used projections (31466, 25832, WGS 84 even) were gone. The list wasn't empty. It's just a very strange collection of obscure projections.

I tried apt-get install --reinstall qgis

I tried purging qgis from the System and reinstalling.

I Keep getting the same log and the same result.

The horrific part is, now I don't have qgis 2.1, because it's not on ubuntugis-unstable anymore, and even worse, I just managed to remove qgis and go back to the qgis.org main, which is Dufour, And I still get the same log message as above, and my projections are still gone. Which means I have no ability to get a functional qgis back with apt-get. I'm scared. Help.

I get the log message when I just install qgis-providers, so it's in there.

Is there anyway I can reinstall the projections?

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Affected QGIS version changed from 2.0.1 to 2.2.0
  • Status changed from Open to Feedback
  • Category set to Build/Install

have you tried update your sources and re-install?

#2 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Feedback to Closed

closing for the lack of feedback.

Also available in: Atom PDF