Bug report #9630

Identify on WMS layers broken

Added by Victor Axbom about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18203

Description

Nothing happens when trying to use the identify tool on a WMS layer on master. This message is logged:

Map getfeatureinfo error: Cannot open /?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetFeatureInfo&BBOX=6374566.55399399250745773,153470.79550213797483593,6374788.18416313454508781,153902.30865831207484007&CRS=EPSG:3007&WIDTH=1102&HEIGHT=566&LAYERS=kba:gcbland&STYLES=&FORMAT=image/png&QUERY_LAYERS=kba:gcbland&INFO_FORMAT=text/html&I=352&J=329&FEATURE_COUNT=10: Path is a directory [/?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetFeatureInfo&BBOX=6374566.55399399250745773,153470.79550213797483593,6374788.18416313454508781,153902.30865831207484007&CRS=EPSG:3007&WIDTH=1102&HEIGHT=566&LAYERS=kba:gcbland&STYLES=&FORMAT=image/png&QUERY_LAYERS=kba:gcbland&INFO_FORMAT=text/html&I=352&J=329&FEATURE_COUNT=10]

Associated revisions

Revision 33a8b634
Added by Jürgen Fischer about 6 years ago

wms provider: fix feature info (fixes #9630)

History

#1 Updated by Giovanni Manghi about 6 years ago

  • OS version deleted (7)
  • Operating System deleted (Windows)
  • Priority changed from High to Severe/Regression

Confirmed here

Map getfeatureinfo error: Protocol "" is unknown [?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetFeatureInfo&BBOX=-39438.70014771050773561,-75120.03420663920405786,-1285.08124076807871461,-44909.50789084970892873&SRS=EPSG:3763&WIDTH=855&HEIGHT=677&LAYERS=CLC06_PT&STYLES=&FORMAT=image/png&QUERY_LAYERS=CLC06_PT&INFO_FORMAT=application/vnd.ogc.gml&X=288&Y=241&FEATURE_COUNT=10]

#2 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF