Bug report #9600

When using the datum transformation dialog the labels of reprojected layers are not reprojected

Added by Giovanni Manghi over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18178

Description

See

http://goo.gl/ccHegM

and/or attached screencast

labels.mp4 (3.69 MB) Giovanni Manghi, 2014-02-19 03:31 AM

vertices_2012.zip (1.09 MB) Pedro Venâncio, 2014-02-19 04:19 AM

Associated revisions

Revision 34f79cf1
Added by Marco Hugentobler over 5 years ago

Make a correct copy of QgsCoordinateTransform for labeling (hope it fixes #9600)

History

#1 Updated by Pedro Venâncio over 5 years ago

This is only noticeable with point layers, because with other geometries it is almost impossible to "fix" the label always in the same relative location. In the screencast I put them always above the point.

I also attatch the sample data we used to test.

#2 Updated by Marco Hugentobler over 5 years ago

  • Status changed from Open to Closed

#3 Updated by Pedro Venâncio over 5 years ago

Confirmed!

Thanks Marco!

Also available in: Atom PDF