Bug report #9590

postgis table primary key choice list mixes fields from different tables or view

Added by Regis Haubourg over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:High
Assignee:Jürgen Fischer
Category:Data Provider/PostGIS
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18170

Description

Hi,
Primary key choice list in postgis connection dialog does show much more field than real table or view has.
Good table fields appears in the lower end of the dropdown list. I can even see technical fields or postgres system table.

This might be related to slow scanning of fields, because too much fields are scanned.

see image here, the field insee_commune is almost always proposed by default when it exists really on a few tables.

qgis_postgis_connexion_field_bug.png (76.2 KB) Regis Haubourg, 2014-02-18 02:58 AM

Associated revisions

Revision 7f5aac30
Added by Jürgen Fischer over 5 years ago

postgres provider: clear primary key for views (potentially fixes #9590)

History

#1 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Open to Closed

#2 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Closed to In Progress
  • Category changed from Data Provider to Data Provider/PostGIS

Not reproducable here, but 7f5aac30 might still fix it.

#3 Updated by Jürgen Fischer over 5 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF