Bug report #9571

Qgis crash when remove group of layers create with python

Added by SC SC about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:18154

Description

hi after that i load many layers i run this code in python console

        li = iface.legendInterface()
        index=li.addGroup("g267") 
        for l in li.layers():
           li.moveLayer(l, index)

it creates group but if i try to delete the group , QGIS crash , this is a problem because i use this code in a plugin too and it crash the same

i use osx
atacchment qgis report crash

crash_report_qgis_group.txt Magnifier - crash report (97.1 KB) SC SC, 2014-02-16 03:00 AM

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Priority changed from Normal to High

#2 Updated by Martin Dobias about 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

I can replicate the problem in QGIS 2.0.1 (on linux), but not with QGIS master, so I assume this has been fixed in the meanwhile.

Also available in: Atom PDF