Feature request #952

Support PostgreSQL uuid type

Added by christiangda - over 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Data Provider
Pull Request or Patch supplied: Resolution:duplicate
Easy fix?:No Copied to github as #:11011

Description

Hi,
Recently I have been working with PostgreSQL 8.3 and uuid data type. When I have a table with uuid data type as primary key, qgis can't show or manipulate it.

History

#1 Updated by Mike Taves almost 11 years ago

A suggested workaround for this is to:
1. drop the primary key constraint
1. add a unique key constraint on the uuid column (former pkey)
1. add a serial column (this could be on the far right-side .. doesn't matter)
1. create a primary key on the newly created serial column

FYI, very few GIS programs allow a non-integer primary key.

#2 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #62

Also available in: Atom PDF