Bug report #9508

Dissolve tool doesn't work

Added by Jean-Michel Follin about 6 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:18099

Description

There is a "vector map not found" error when i try to execute dissolve tool. It doesn't work with both temporary and permanent file (for saving dissolved layer) under qgis 2.0.1, but works fine under qgis 1.8.

pb_dissolve_qgis201_1.jpg - dissolve menu (53.5 KB) Jean-Michel Follin, 2014-02-07 02:29 AM

pb_dissolve_qgis201_2.jpg - execution error (104 KB) Jean-Michel Follin, 2014-02-07 02:29 AM

History

#1 Updated by Filipe Dias about 6 years ago

  • Category changed from GRASS to 94

Have you tried to upgrade "Processing" from the plugin installer?

I just tested v.dissolve with a shapefile and it worked as expected. Could you share your shp so we could test?

#2 Updated by Giovanni Manghi about 6 years ago

  • Status changed from Open to Feedback

I usually get the same issue when in the table of attributes there is a column with a reserved/invalid name, like "desc" or "ctãç".

Please have a look at your data, if you are unsure attach here a sample.

#3 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

closing for lack of feedback.

#4 Updated by Giovanni Manghi almost 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF