Bug report #948

WMS Layer GetMap Request with Wrong Parameters WIDTH=1&HEIGHT=1

Added by LuizDomingues53 - over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11007

Description

After correction to WIDTH=600&HEIGHT=400, GetMap request works as intended.
QGIS 0.9.1 Error Report Follows
Server Response:
Could not draw WMS RGA because:
(Unknown error code from a post-1.3 WMS server)
The WMS vendor also reported:
msDrawMap(): Image handling error. Unable to initialize image.
msCalculateScale(): General error message. Invalid image extent, minx=-1.#IND00,
miny=-1.#IND00, maxx=-1.#IND00, maxy=-1.#IND00.

This is probably due to a bug in the QGIS program. Please report this error.
Tried URL: http://localhost/cgi-bin/mapserv.exe?MAP=/ms4w/apps/gmap/htdocs/gmap75_wms.map&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&BBOX=-172.367000,35.667300,-11.562400,83.829300&SRS=EPSG:4326&WIDTH=1&HEIGHT=1&LAYERS=bathymetry&STYLES=&FORMAT=image/png&TRANSPARENT=TRUE

Edited URL (works fine): http://localhost/cgi-bin/mapserv.exe?MAP=/ms4w/apps/gmap/htdocs/gmap75_wms.map&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&BBOX=-172.367000,35.667300,-11.562400,83.829300&SRS=EPSG:4326&WIDTH=600&HEIGHT=400&LAYERS=bathymetry&STYLES=&FORMAT=image/png&TRANSPARENT=TRUE

History

#1 Updated by LuizDomingues53 - over 12 years ago

Workaround:
"Zoom Full (F)" solves the problem.

#3 Updated by LuizDomingues53 - about 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Now working OK. Many zooms and full view tested.

#4 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF