Feature request #9477

GDAL translate: support ESRI rasters folders names as inputs

Added by Filipe Dias over 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GDAL Tools
Pull Request or Patch supplied:No Resolution:
Easy fix?:No

Description

GDAL translate: conversion of ESRI Raster to tiff has a bug

ESRI rasters are viewed by GDAL as a folder with several files (see attached esri raster) and not as a single file. To convert an ESRI raster the user has to enter the folder and selecte hdr.adf as input and only then can the conversion begin. This is a bug since GDAL translate (when run from the command line) can do this by simply pointing the folder.

The fix for this bug should also take into account that the output of gdal_translate takes the correct name of the ESRI raster, which in this case is "test_raster" and not "hdr".

I'm setting the priority to High because this bug doesn't allow users to do batch conversion (i.e., select several rasters stored in a folder) of ESRI rasters.

test_raster.zip (93.5 KB) Filipe Dias, 02/02/2014 10:49 AM

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Target version set to Version 2.2
  • Priority changed from High to Normal
  • Subject changed from GDAL translate: conversion of ESRI Raster to tiff has a bug to GDAL translate: support ESRI rasters folders names as inputs
  • Tracker changed from Bug report to Feature request

There is no crash or data corruption, so I'm lowering the priority.

The issue is not in GDAL (that by the way would have lead to close this ticket as invalid) but in gdal tools:

GDAL can use as inputs the folders (names) ESRI rasters are contained, GDAL tools can't, so it is not possible to do a batch job to convert many ESRI rasters to other formats.

#2 Updated by Filipe Dias over 3 years ago

I looked into GRASS and SAGA and both have the same problem, which means that in the FOSS GIS world, batch conversion of ESRI rasters is problematic. Unfortunately many organizations have their rasters saved in this format and it's a pain to work with them (or convince them to change to QGIS) because of this.

There are of course workarounds [1] but it would be very important to have this fixed in QGIS:

[1] http://gis.stackexchange.com/questions/54819/gdal-translate-converting-esri-grid-to-geotiff-in-batch

#3 Updated by Jürgen Fischer almost 3 years ago

  • Target version changed from Version 2.2 to Future Release - Lower Priority

#4 Updated by Filipe Dias over 2 years ago

  • Status changed from Open to Closed

I'm closing this in favour of a ticket filed for Processing/GDAL.

Also available in: Atom PDF