Bug report #947

Meter - Feet Conversion Broken

Added by David A- Riggs - over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Legend
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:11006

Description

When changing a project's Map Units from Meters to Feet (or vice versa), the value displayed in the scalebar, and the values given by the distance (ruler) tool are wildly wrong.

1. Create new project with a single layer. Set correct project Projection and Map Units (eg. UTM NAD83).

2. Scale bar read eg. 50 km

3. Measure distance between two points, eg "Segments (in meters)" 88,711.91, total 88.71 km

4. Change Map Units in project Properties to Feet. Hit refresh.

5. Scalebar is same size, now says 9.4697 miles (WRONG: should be ~31 miles)

6. Measure same distance, eg "Segments (in feet)" 89,177.93, total 16.89 mile (WRONG: the displayed number of segments are really meters, the "total" count converts feet to miles, should be converting meters to miles or should be counting feet instead of meters)

History

#1 Updated by Magnus Homann over 12 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

This is the intended behaviour. It is not meant to perform conversion, but to specify that one unit of the map represent a foot, meter or degree. Mostly used when no projection is appropriate (such as drawing a plan of your house).

#2 Updated by Anonymous about 11 years ago

Milestone Version 0.9.2 deleted

Also available in: Atom PDF