Bug report #9468

cannot add ring in a polygon

Added by Denis Rouzaud almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18060

Description

I received a mail from someone having troubles to add ring in polygons on postgis layers.
He tried both 2.0 and master, without success.

Attached a desktop recording.

Does someone know what to look for?
I have pretty much no idea as I can't reproduce.

Associated revisions

Revision a0fc024e
Added by Jürgen Fischer almost 6 years ago

enable geometry changing polygon tools only when 'change geometry' capability is available.
OGR's postgresql driver apparently doesn't support geometry updates (fixes #9468)

History

#1 Updated by Denis Rouzaud almost 6 years ago

could not join the video, here it is:
http://youtu.be/d06KI0igcP0

Content:
  • add a ring to a fresh polygon in shapefile works
  • add a ring to a fresh polygon to a postgis layer via OGR doesn't work.

#2 Updated by Rémi Bovard almost 6 years ago

Is the geom MultiPolygon?

#3 Updated by Denis Rouzaud almost 6 years ago

his answer:

I am having some problems with registration.
I will try later on again.
My geometry is Polygon, but I have just tried with MultiPolygon as well and still it is the same problem.

#4 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Closed

#5 Updated by Jürgen Fischer almost 6 years ago

Jürgen Fischer wrote:

Fixed in changeset a0fc024e76b9f40cff1bfde76e6dbf8111c7eb3a.

Use the native postgres provider (ie. Add PostGIS layers instead of Add Vector layer), if you want to update geometries.

Also available in: Atom PDF