Bug report #946

New Project Should Get Projection of First Loaded Layer

Added by David A- Riggs - over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Projection Support
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:11005

Description

In previous versions of QGIS, a new project would be assigned the same projection as the first loaded layer. With 0.9.2rc1, a new project seems to always be assigned "WGS84" until the project Projection is manually changed, even after loading a vector or raster layer. Checking the properties of the layer itself shows that it is assigned the correct projection.

History

#1 Updated by Magnus Homann over 12 years ago

I think this changed in early 0.8 or perhaps even earlier. The change was because the logic behind finding the projection of the layer got really messy, cinsdering that the later projection can get read from the project also.

I'm not really sure that the concept of changing projection depening on which layer is loaded is the best.

#2 Updated by Maciej Sieczka - about 12 years ago

In a duplicate #933 there is some more info on the subject.

#3 Updated by Magnus Homann almost 12 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This is the intended behaviour.

Considering what happens if you first set the project CRS and then start adding layers. if the layer you add first is not teh same as you just set, you have to reset it again. Minimizing side effects, we should stick with the current behaviour.

#4 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF