Bug report #9442

Digitizing broken in QGIS master

Added by Giovanni Manghi almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18036

Description

It seems that editing broke in QGIS master

Testing on

2.1.0+git20140126+55727f7~precise-ubuntugis1

Trying move a node sometimes does nothing and others go crazy by placing the node in the wrong place, very far from the feature being edited.


Related issues

Duplicates QGIS Application - Bug report #9463: move vertex does not work anymore Closed 2014-01-30

Associated revisions

Revision 70c59498
Added by Jürgen Fischer almost 6 years ago

fix QgsGeometry::moveVertex on polygon (fixes #9442)

History

#1 Updated by Denis Rouzaud almost 6 years ago

  • Status changed from Open to Feedback

I can't reproduce with today's master on ubuntu

#2 Updated by Salvatore Larosa almost 6 years ago

  • Subject changed from Digitizing broken in QGIS master (2.1.0+git20140126+55727f7~precise-ubuntugis1) to Digitizing broken in QGIS master

Hi, I can reproduce the issue on my machine (7a9e682),
but only using Polygon features with OGR and Spatialite providers. PostGIS works fine!

#3 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Feedback to Open

Issued confirmed for shapefiles, PostGIS ok.

#4 Updated by Denis Rouzaud almost 6 years ago

  • Assignee set to Jürgen Fischer

I confirm, It happens with the node tool, and for Postgis (not tested other providers) but for polygons only.

Duplicate with #9463:

the problem seems to be here
https://github.com/qgis/QGIS/blob/master/src/core/qgsgeometry.cpp#L1201
nPoints is 0, at least this is where it returns false in my case.

#5 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF