Bug report #935

no layer name if the layer loaded from CLI

Added by cgs_bob - over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Unix Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10994

Description

The summary says it all.

Associated revisions

Revision 630ee1be
Added by Jürgen Fischer about 12 years ago

fix #935

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision f882e969
Added by Jürgen Fischer about 12 years ago

fix #935

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Maciej Sieczka - about 12 years ago

I'm extending the description to reflect that the issue is not limited to rasters only. E.g.:

qgis dir/*.shp

will also yield a set of layers without a name.

#2 Updated by Maciej Sieczka - about 12 years ago

As of the behavior is different for Shapefiles - the full path to file is present as the layer name. This is bad too. Filename alone suffices. (Rasters loaded from CLI still don't have any layer name at all.)

#3 Updated by Jürgen Fischer about 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in f882e969 (SVN r9221)

#4 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF