Bug report #9345

WMS axis ordering depending on CRS a 2.0 rollout stopper

Added by Bernt Rane over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Alvaro Huarte
Category:Browser
Affected QGIS version:2.0.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17948

Description

The move in wms 1.3.0 to a more strict axis ordering and a changed behaviour from qgis 1.8 to 2.0 is turning into a major obstacle in our QGIS 2.0 migration.

As this is now implemented in QGIS 2.0 at least when talking to geoserver wms services around the world it makes it rather difficult for users, especially non-expert users who are in majority in our organisation, to add wms services. The problem lies in when or not to click Invert axis orientation for a wms source.

In QGIS 1.8 you could add WMSs without problem in all the crs we come across. wgs84, webmercator, etrs90 etc.
In QGIS 2.0 you will have to know, depending on the projection you are working in, when to go in and change the axis orientation, and then remember to uncheck the next time if you are working in another crs.

This can be tested using for example the demoserver http://demo.opengeo.org/geoserver/wms using the layer osm:osm.
- WGS84 (EPSG:4326) will work fine.
- Setting the project crs reproject property to WGS84 / Pseudo Mercator (EPSG:3857) and adding the layer as well in WGS84 / Pseudo Mercator also works fine.
- Setting the project crs reproject property to ETRS89 / ETRS-LCC (EPSG:3034) and adding the layer as well in ETRS89 / ETRS-LCC (EPSG:3034) will not work properly. There will be a map but it will be confusing since pans and zooms create the (seemingly) most irrational behaviour. You then have to know that you have to edit the wms source and set the property Invert axis orientation, save the source and then add the layer. (And remember to turn this back the next time...)

As seen in mailing list discussions and reports this is probably a well known issue and with well understood reason. Nevertheless it is a real show stopper.

There are specifically a number of European CRS that will create this user trouble. ETRS89 / ETRS-LCC (EPSG:3034) and ETRS89 / ETRS-LAEA (EPSG:3035) being the most important since these are mandatory to support for all European official authorities by the INSPIRE directive. Also many (majority?) of the national CRS relies on ETRS89 and should therefore have the same problem (I said after testing some but not all...).

There are suggestions to changed the behaviour in QGIS but controlling wms version but we dont have any possibility currently to controll the rollout of QGIS that would make such a change roulloutable unfortunately.
Informing users on when to select Invert axis orientation and when not to is not one we really are so fond of, most of them being non-expert as mentioned.

Our status for now is to stay put in QGIS 1.8. But since QGIS 2.0 has the "ArcGIS killer GUI" we would be interested in having a migration to QGIS 2.0 throughout the organisation as an option, which we don't currently due to this issue.

I do not have a solution to suggest for this. Can anyone give some hint to if QGIS have any plans to adress this issue in coming versions? Or any other workaround out there?
All input and help appreciated!


Related issues

Related to QGIS Application - Bug report #4443: WMS 1.3.0 axis order Closed 2011-10-25

Associated revisions

Revision 2e9d3a8c
Added by Jürgen Fischer over 5 years ago

CRS axis inversion retrieval update:
- back to OGRGetAxis() as OSREPSGTreatsAsNorthingEasting() was introduced with
GDAL 1.10 (fixes builds with earlier GDALs; related to #9345)
- keep using OSRImportFromEPSGA() as that's what retrieves the axis orientation
(but only for EPSG codes)

History

#1 Updated by Alvaro Huarte over 5 years ago

  • Assignee set to Alvaro Huarte

#2 Updated by Alvaro Huarte over 5 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • Resolution set to fixed/implemented

Hi Bernt, I propose this pull request:
https://github.com/qgis/QGIS/pull/1081

Can you test it ?

Alvaro

#3 Updated by Bernt Rane over 5 years ago

Alvaro Huarte wrote:

Hi Bernt, I propose this pull request:
https://github.com/qgis/QGIS/pull/1081

Can you test it ?

Alvaro

Would be happy to, we have not the resources to build qgis however. Is there any way to get this in an installation for windows, if so we would be very happy to test this!!!
Bernt

#4 Updated by Alvaro Huarte over 5 years ago

  • Status changed from Open to Closed

Hi Bernt, this patch was merged to master.
Next release will contain it!

Best Regards
Alvaro

#5 Updated by Bernt Rane over 5 years ago

Alvaro Huarte wrote:

Hi Bernt, this patch was merged to master.
Next release will contain it!

Best Regards
Alvaro

We will sleep extremely well tonight, and wake up on monday eagerly looking forward to the next release!!!
Thanks so very much, Alvaro!
Bernt

Also available in: Atom PDF