Bug report #9343

Raster artefacts on data / no data border

Added by Radim Blazek almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:Radim Blazek
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17946

Description

Artefacts appear within raster extent on the left/right side of no null data and on the left / right side of raster extent in pixels with no data, i.e. in pixels which should be transparent.

The artefacts only appear when rendered on screen, screen saved as image or if printed via composer. They don't appear if the raster is saved as rendered image. It means that the raster chain seems to be OK and the artefacts are somehow generated when rendered raster QImage is painted on canvas (blended?).

The artefacts appear in following small patterns

0 0 0 0 or 0 1 1 1
1 0 0 0    0 0 1 1
1 1 0 0    0 0 0 1
1 1 1 0    0 0 0 0

In attached artefacts1.png snapshot is background color set to black, raster no null values are rendered green and white are artefacts.

artefacts1.png (4.56 KB) Radim Blazek, 2014-01-15 04:22 AM

History

#1 Updated by Radim Blazek almost 6 years ago

The artefacts have the same color as RGB part of QgsRasterRenderer::NODATA_COLOR = qRgba( 255, 255, 255, 0 ). It means that the artefact pixels are somehow rendered with alpha = 255 instead of 0.

#2 Updated by Radim Blazek almost 6 years ago

  • Status changed from Open to Closed

Fixed in 00efc46784.

This bug was caused by first attempts to fix #9101.

Also available in: Atom PDF