Bug report #9243

libotbossimplugins.so undefined symbol error

Added by Christopher von Nagy over 6 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:17861

Description

Hi,

When executing cammands in the processing toolbox involving the OTB toolkit I receive the following error:

OTB execution console output
/usr/bin/otbApplicationLauncherCommandLine: symbol lookup error: /usr/lib/otb/libotbossimplugins.so.18162.1: undefined symbol: _ZNK28ossimImageHandlerFactoryBase12openOverviewERK13ossimFilename

I am using QGis 2.0.1 via UbuntuGIS. The command also happens to fail on OSX with an indication that the generated file could not be loaded.

Please let me know what else I can supply to document the issue.

Cheers

History

#1 Updated by Christopher von Nagy over 6 years ago

The particular tool in question is pansharpening.

#2 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

The error seems to be an issue in OTB tool, not how processing handles it.

You can try running the same OTB tool by using the command line, if you gets the same error is OTB problem.

#3 Updated by Jürgen Fischer over 6 years ago

  • Resolution set to up/downstream
  • Status changed from Feedback to Closed

closing for the lack of feedback.

#4 Updated by Giovanni Manghi about 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF