Bug report #9201

Select by Location Failure on complex polygons

Added by Neil Benny almost 6 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Processing/QGIS
Affected QGIS version:2.0.1 Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:17829

Description

There is an issue with large complex vectors and the Select by Location tool.

I have a polygon which has 350,000 nodes and 1200 multiparts. It is the way flood data in Scotland is provided by the environment agency. Performing a select by location causes the system to slow and eventually crash. There is no error message.

More info:

http://gis.stackexchange.com/questions/79885/qgis-2-0-performance-issue-when-selecting-by-location-on-a-complex-dataset?noredirect=1#comment110005_79885

History

#1 Updated by Matthias Kuhn almost 6 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

#2 Updated by Giovanni Manghi almost 6 years ago

  • Target version set to Future Release - High Priority
  • Status changed from Open to Feedback
  • Category set to 44

Can you share the data that causes the issue?

#3 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Closing for lack of feedback/sample data to replicate.

#4 Updated by Neil Benny over 5 years ago

Just for information - I have tested the data on the new version (2.2) and this is no longer an issue.

#5 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF