Bug report #9149

Overlay and Soft Light blend modes do not blend with vectors

Added by Evan Derickson over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17782

Description

Expected behavior
When overlaying a raster on top of a vector layer, the Overlay and Soft Light blend modes should blend with the vector as they would with a raster. See fig1, where the Hard Light mode works as expected.

Actual behavior
The Overlay and Soft Light blend modes do not interact with underlying vector layers at all, leaving the appearance of said vectors being overlaid upon the raster. (Figs 2 and 3)

All images are captured with the same layer order, the only difference being the blend mode selected for the hillshade. Note the change in appearance of the contours and road on the bottom of each image between figs 1 and 2.

hardlight.jpg - Fig1. Hard Light (Works as expected) (92.2 KB) Evan Derickson, 2013-12-01 05:08 PM

softlight.jpg - Fig2. Soft Light (Does not work as expected) (93.9 KB) Evan Derickson, 2013-12-01 05:08 PM

overlay.jpg - Fig3. Overlay (Does not work as expected) (97.6 KB) Evan Derickson, 2013-12-01 05:08 PM

History

#1 Updated by Evan Derickson over 6 years ago

It appears I am not used to Redmine's formatting. Could someone with the appropriate privileges please correct it for me?

#2 Updated by Evan Derickson over 6 years ago

  • Status changed from Open to Closed

Upon further testing it appears that I am incorrect; blend modes seem to be working as intended. I will reopen if I find that I was originally correct.

Also available in: Atom PDF