Bug report #9103

Error downloading OSM data

Added by Noone Noone over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17748

Description

Hi, QGIS 2.0 introduces a new OSM tool that allows to get the corresponding area of a layer directly from OSM and store it in a .osm XML file.

I tried multiple times, but just get always this response:

Error downloading http://overpass-api.de/api/interpreter?data=(node(7.11345e+06,1.27115e+06,7.11383e+06,1.27162e+06);%3C;);out; - server replied: Bad Request

Comparing with the offial request, it seems that coordinates need to formated without exponents and maybe the end is wrong.
http://wiki.openstreetmap.org/wiki/Overpass_API/Language_Guide#All_data_in_a_bounding_box

Obviously, the call is wrong constructed
P.S. I guess more OSMappers will come and work with QGIS. So I recommend to create a appropriate category :)


Related issues

Duplicates QGIS Application - Feature request #8709: Easier import of OSM data: bounding box Closed 2013-09-27

History

#1 Updated by Matthias Kuhn over 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF