Bug report #9095

Shape file points not appearing in 2.0.1

Added by Daniel Kranich almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17740

Description

I have a shape file that is a point layer which has been working fine and displaying fine in 1.8. When I open the layer in 2.0.1, The symbols no longer appear on the map. The attribute table still has all the data, and If I select one and pan the map to that selection, It zooms in to where that particular point should be but the point is not visible on the map.

I have checked out the symbology and there is no reason for the points to not show up (checked transparency/size etc). I also tried removing the layer, and re-adding it and the same problem occurs. I also tried creating a new project and adding the shape file as a layer and the same problem occurs. I have also double checked that it is the top layer and should be rendered on top of everything else, and I double checked the Coordinate system. Somehow the points are there, and when you go to a specific point, it takes you to the right place, but the point just isn't appearing on the map.

Some more detail:
-It seems that it is only this particular shapefile.
-I can see the points if I am zoomed out far enough, but as I zoom in, they disappear.
-When zoomed out far enough to see them, I am unable to select them using the rectangle select tool
-This is the case even if I load it into a new project.
-If I select a specific point in the attribute table and hit the "zoom to selected rows" button, it seems to take me to the correct place, however the points don't appear.
-There are a few points that actually DO appear.
-ALL the points appear at ALL zoom levels in 1.8
-I have tried messing with the "Scale Dependent Rendering" and that changes nothing.

Here are some screenshots:
The points on the far upper right are the ones I would like to
see/manipulate: http://prntscr.com/25apve
After zooming in: http://prntscr.com/25aqic

Here is a link to download two shape files. "Water Nodes" is the one that is a problem. the "Rangeview" shape file is there as reference for the general area where some of the Water Nodes should be appearing. Both are set to EPSG:26934 - NAD83 / Alaska zone 4 coordinate system: http://www.mediafire.com/download/l8nhd1xzmg3v6z2/WaterNodes.zip

Also, The "Rangeview" Shape file does not have any attributes but should show up as a visual reference. there should be at least 10 or 20 points from the "Water Nodes" layer that show up within the area of the "Rangeview" layer. See the screenshots above for additional reference.

History

#1 Updated by Daniel Kranich almost 6 years ago

  • Status changed from Open to Closed

Well I accidentally found the solution to my problem. I found that there was a point in the attribute table that had NULL for every field. I deleted that point and saved the shape file and all the points re-appeared.

Not sure if simply editing and saving would have fixed it or simply deleting any point would fix it. But its now fixed for me and that makes me satisfied.

Also available in: Atom PDF