Bug report #9088

Text Annotation Symbols size is wrong in map composer

Added by Geoff Owen almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Martin Dobias
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17733

Description

I am able to add text annotaion to map canvas without any problem.
Problem arises when going to map composer.
Text annotation symbol is very very small, no matter what size I make it in map canvas.
Seems to happen whatever symbol I use (circle, square triangle etc).
Thanks

Associated revisions

Revision 40b48849
Added by Martin Dobias over 5 years ago

Fix #9088 (Text Annotation Symbols size is wrong in map composer)

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback
  • Target version changed from Version 2.0.0 to Future Release - High Priority

do you have any evidence if this was working the right way in qgis 1.8?

#2 Updated by Geoff Owen almost 6 years ago

  • Assignee set to Giovanni Manghi

Hello
Text annotation symbols worked fine with QGIS 1.8.
Size of symbol on map canvas was the same on map composer.
Thanks

#3 Updated by Giovanni Manghi almost 6 years ago

  • Category changed from Labelling to Map Composer/Printing
  • Priority changed from Normal to Severe/Regression

I'll tag this a regression, meanwhile can you test QGIS master and see if by any chance this has been fixed there? thanks.

#4 Updated by Geoff Owen almost 6 years ago

Hello Giovanni
I downloaded Master on 21 November.
The text annotation symbol problem is the same as that on stable version.
Regards
Geoff

#5 Updated by Giovanni Manghi over 5 years ago

  • Affected QGIS version changed from 2.0.1 to master
  • Status changed from Feedback to Open

#6 Updated by Giovanni Manghi over 5 years ago

  • Assignee deleted (Giovanni Manghi)

#7 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Future Release - High Priority to Version 2.2
  • Operating System deleted (Win 7)

Confirmed as a regression since 1.8

#8 Updated by Giovanni Manghi over 5 years ago

  • Subject changed from Text Annotation Symbols to Text Annotation Symbols size is wrong in map composer

#9 Updated by Martin Dobias over 5 years ago

  • Assignee set to Martin Dobias

#10 Updated by Martin Dobias over 5 years ago

  • Status changed from Open to Closed

#11 Updated by Geoff Owen over 5 years ago

Thanks Martin.
Regards
Geoff

Also available in: Atom PDF